Ubuntu+DYI cable(w/ arduino board)+Momo Racing Wheel+PS4

Discuss everything to do with GIMX here
Post Reply
ben
Posts: 6
Joined: Wed Dec 30, 2015 8:50 pm

Ubuntu+DYI cable(w/ arduino board)+Momo Racing Wheel+PS4

Post by ben » Wed Dec 30, 2015 9:02 pm

Hi guys, first a big THANK for the author of this app and DIY cable for allowing us FINALLY to play with our old but still good wheels on the new console generation at very low cost (12,50€). It was tested successfully on Driveclub and i will bought Project Cars to complete this test.

I didn't notice any lag in my experience with Drive-club and the FFB is well calibrated. I can just say that it's a REAL pleasure playing cars game with a wheel on a PS4, it is even more a pleasure when you don't have to spent 350€ to buy their f*****g new wheels. I bought an used momo 50€ many years ago and it still does a solid job.

That being said, I have an average level in programing and I’m newbie in everything related to electronics so I will tell how I get my Momo racing to work after 1 day of trial & error, it may help some of you.

Hardware:
# Computers
- 06’ Macbook running Ubuntu 15.04
- Macbook air 2015 running El Capitan
# Wheel
- Momo racing
# Console
- PS4
# DIY cable (components bought on eBay) Total cost: 12,50€
- USB/TTL converter: BS USB UART CP2102 (4,92€)
- Arduino board: Pro Micro ATmega32U4 (7,58€)
# Hub USB
- Belkin USB2.0 4 ports

I pretty much followed the tutorials on the site, used the softwares and the firmwares downloaded from here.
I just had some difficulties to get Ubuntu on my old mac as it broke the multi boot with MacOS and Windows seven but after some time I figure how to solve it (installed rEFit).

DIY cable
- Introduction
I did not find a Teensy board on a regular site so I decided to get a very cheap ATmega32u4 board on eBay. I had to solder the pins to the boards but that’s pretty easy with some tin and a basic soldering iron. You’ll find videos on youtube showing how to do it.

- Cabling:

USB/serial converter > Arduino Board : Wire color
GND > GND : Purple
RXD > TX0 : Black
TXD > RX1 : White

- Firmware upload to Arduino board
Note: You have to connect the micro USB to the computer.

The part which get me the more troubles. I tried many times on ubuntu with avrdude then with osX with the Arduino application and with avrdude in the terminal.
And every time I get a f*****g message « avrdude: error: buffered memory access not supported. Maybe it isn't a butterfly/ AVR109 but a AVR910 device? ».
And I finally i got it to work. It was because a dumb program was already flashed on the the board, some basic « Hello Word » with the 2 leds blinking alternatively. And when that program was running, there was no way to flash anything on the board! I tried to reset the board (Connect GND to RST pin twice) many many times but it wasn’t working. Each time, the 2 red lights were stoping to blink, the green light was continuing to be ON but after a moment the red leds were starting to blink again.
So the solution was to reset the arduino board (GND to RST with a wire twice) and IMMEDIATELY launch the avrdude command to flash the firmware (before the 2 leds starts blinking again). I had the following command line prepared to be executed in the macOS terminal and just pressed the enter button after having reset the board.

avrdude -p atmega32u4 -c avr109 -P /dev/tty.usbmodem1411 -D -U flash:w:/Users/Ben/Desktop/GIMx/firmwares-5.4/EMUG29PS4/atmega32u4.hex:i

You will just have to replace the following in the command:
/dev/tty.usbmodem1411 by whatever port your board is connected on.
/Users/Ben/Desktop/GIMx/firmwares-5.4/EMUG29PS4/atmega32u4.hex by the location where you put the firmware.

And now, you’re pretty done.

Getting start
Note: 3 available USB ports are necessary on the computer.
Plug :
- the Momo Racing wheel to an usb port on the computer
- the micro USB cable between the arduino board and the PS4
- the USB/TTL converter directly on the PC
- the PS4 pad (turned off) on the PC (with the standard micro usb cable)

PS4 Game Pad ---- PC
Wheel ----- PC
PS4 ---- Arduino Board - USB/TTL ---- PC

1. Launch GIMX and download the momo racing configuration.
2. Select the port and the DIY usb adapter.
3. Turn ON the PS4
4. Click on the START button in Gimx
5. THAT’S IT! Use the gamepad to navigate in the PS4 menu and launch the game, play with the wheel as you wish!!!


:D :D :D ENJOY!!! :D :D :D

ben
Posts: 6
Joined: Wed Dec 30, 2015 8:50 pm

Re: Ubuntu+DYI cable(w/ arduino board)+Momo Racing Wheel+PS4

Post by ben » Wed Feb 03, 2016 8:53 pm

Project cars is working PERFECTLY too :D
Next game : Dirt Rally when it comes out.

And i bought a raspberry pi 2, I'll try some time to make it work automatically. :P

EDIT: to make the cars "drivable", I had to increase a lot the sensitivity in the Project Cars configuration (to something like 65). Otherwise, the car was spinning in every turn, very difficult to handle. :lol:
Last edited by ben on Sun Feb 07, 2016 5:16 pm, edited 1 time in total.

User avatar
Matlo
Posts: 5535
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: Ubuntu+DYI cable(w/ arduino board)+Momo Racing Wheel+PS4

Post by Matlo » Wed Feb 03, 2016 9:41 pm

Thanks for the feedback :)

I added a note that explains the bootloader is only executed briefly.
GIMX creator Donate Shop

ben
Posts: 6
Joined: Wed Dec 30, 2015 8:50 pm

Re: Ubuntu+DYI cable(w/ arduino board)+Momo Racing Wheel+PS4

Post by ben » Sun Feb 07, 2016 4:22 pm

Many THANKS to YOU for your amazing work :D

So I give it a try on a RPI2 today. I plug everything into the RPI usb ports (no need of USB hub in my case) (I have a 5V micro USB DC adapter).

It worked like a charm ! I followed the instructions on the wiki to install gimx and it was working out of the box.

Next step: start gimx automatically on boot.
I think I will had something like this in the /ETC/rc.local file:

$ nano /etc/rc.local
add: "gimx -c LogitechMomoRacing_G29.xml -p /dev/ttyusb0" at the end of the file.
Exit with ctrl+x then save.

I wonder if it will work in any case (wondering if the pi will always assign ttyusb0 to the wheel).

And maybe add a little very simple script to check if the momo is connected then start gimx else do nothing.

Code: Select all

#!/bin/sh
 [ -f /dev/ttyusb0 ] &&  gimx -c LogitechMomoRacing_G29.xml -p /dev/ttyusb0
I'm a total newbie in programming but I will try and let you know. :P

Danzig
Posts: 1
Joined: Fri Feb 12, 2016 5:31 am

Re: Ubuntu+DYI cable(w/ arduino board)+Momo Racing Wheel+PS4

Post by Danzig » Fri Feb 12, 2016 5:33 am

Would be great if you find out how to automate the process on raspberry pi , i've just ordered the same parts to use my logitech momo too.

so thanks in advance for the tips, i'm sure they will come in handy :)

ben
Posts: 6
Joined: Wed Dec 30, 2015 8:50 pm

Re: Ubuntu+DYI cable(w/ arduino board)+Momo Racing Wheel+PS4

Post by ben » Sat Feb 13, 2016 7:03 pm

Unfortunately it didn't worked with the rc.local method.

The command line was not correct to launch GIMX (the correct one is

Code: Select all

gimx -c LogitechMomoRacing_G29.xml -p /dev/ttyUSB0
) instead off usb0 but even after fixing this I wasn't able to make it worked.

Will try other things ;)

ben
Posts: 6
Joined: Wed Dec 30, 2015 8:50 pm

Re: Ubuntu+DYI cable(w/ arduino board)+Momo Racing Wheel+PS4

Post by ben » Thu Apr 07, 2016 9:40 pm

No progress on automating rpi but an update on game compatibility :

Dirt rally 4 is working GREAT !!!

From time to time I have an issue with the wheel not correctly aligned (on the screen 30° right, 0° in reality) but 90% of the time it's working great. Maybe it's just my wheel which is faulty.

I deeply recommend this game, best driving experience since... pff I don't even remember. :o

Post Reply