Difference between revisions of "Development on Windows"

From GIMX
Jump to: navigation, search
(Cloning project)
Line 59: Line 59:
 
===Cloning project===
 
===Cloning project===
  
Copy the following URL: https://github.com/matlo/GIMX.git<br />
+
Copy the following URL: '''https://github.com/matlo/GIMX.git'''<br />
 
Click on "Window > Show View > Other...", select "Git repositories", and click on "Open".<br />
 
Click on "Window > Show View > Other...", select "Git repositories", and click on "Open".<br />
 
Type Ctrl+V. A "Clone Git Repository" window should appear.<br />
 
Type Ctrl+V. A "Clone Git Repository" window should appear.<br />

Revision as of 16:51, 23 February 2019

Other languages:
English • ‎français

This wiki explains how to install a compilation environment (based on Msys2/mingw64) to build GIMX.
It also explains how to install Eclipse CDT and perform a checkout.
Unless otherwise specified, perform a default installation (default directories, etc).

Msys2/MinGW64

Download and install Msys2.
Make sure to follow the instructions from the Msys2 wiki.

If you are running a 32-bit Windows, install the i686 version.
If you are running a 64-bit Windows, install the x84_64 version.

Checkout installation and build tools

pacman --noconfirm -S git
git clone https://github.com/matlo/GIMX-build.git

Development tools

Run mingwXY.exe (XY=32 or 64) and type:

cd GIMX-build/windows
./install.sh

Inno setup

Download and install Inno setup.

Automated command-line build

Run mingwXY.exe (XY=32 or 64) and type:

cd GIMX-build/windows
./build.sh

All binaries are copied into <path to msys>\home\<username>\GIMX\setup, e.g. C:\msys32\home\matlo\GIMX\setup.
A setup file is also created.

Eclipse IDE

This part is only useful in case you intend to modify the source code. If you only want to build GIMX, you can skip it.
Eclipse is an IDE that can be stacked onto the Msys2/MinGW64 compilation toolchain.
Be sure to have a java JRE installed on your system.
Download Eclipse CDT 2018-12. Unzip it to wherever you want.
Run eclipse.exe.

Cloning project

Copy the following URL: https://github.com/matlo/GIMX.git
Click on "Window > Show View > Other...", select "Git repositories", and click on "Open".
Type Ctrl+V. A "Clone Git Repository" window should appear.
First step defines the repository to import. Click on "Next".
Second step defines the branch selection. Select the branches you are interested in. "master" branch contains latest stable source code. Click on "Next".
Third step defines local destination. A standard value for "Directory" is "C:\Users\<username>\git\GIMX". Make sure to select "Clone submodules". Click on "Finish".

Importing project

In the "Git Repositories" view, right click on the cloned git repository, and click on "Import Projects...". Select the project folder (for example "GIMX") and click on "Finish".