Cannot update firmware

Need help? Ask here and someone will help
Post Reply
Posts: 1
Joined: Sat Nov 13, 2021 11:23 am

Cannot update firmware

Post by sonnytron »

I connect both ends to the same computer, USB is not a sleeping port.
Windows 10 x64 Home Edition
Updated all the drivers, everything is up to date.
Internet is working fine.

I choose "G27" from the list, and hit "OK", and I get the confirmation prompt for GIMX adapters only, and then it tells me to disconnect the USB cable and reconnect it.
As soon as I pull the cable out, it gives me a "No new device found within 10 seconds" error.

I purchased my GIMX adapter directly from your store. It's been in the box since I bought it because I never had time to test it.

I have tried a different cable and it didn't work. Also this is a brand new Xbox One controller usb cable and I verified it works with my wired controller.

I don't think this is a cable issue. I also tried on my desktop and another laptop, both with updated Arduino drivers. I believe this device is faulty... Was it tested before being shipped?
User avatar
Posts: 258
Joined: Thu Jul 10, 2014 8:16 pm
Location: Sweden

Re: Cannot update firmware

Post by ckaiycool »

Did you do it like this:
Connect both sides to your computer
Start gimx-loader, select the firmware, click on "Load", and "Validate" a single time
Unplug the USB cable from computer (pro micro side)
Click on "Validate" (be quick)
Replug the USB cable (be quick)
Consoles Playstation 3 Slim *OFW*|OG XBOX *Aladdin Modchip*
Gimx Adapter Arduino pro micro ATMEGA32U4
Mouse Logitech G403
PSN PS3 ckaiy
Config Repository ... sp=sharing
User avatar
Posts: 1159
Joined: Thu Apr 28, 2016 12:47 pm
Location: Poland

Re: Cannot update firmware

Post by GoDlike »

Make sure you replug the correct cable. Try the other end.
My hardware: PS3 Slim CFW 4.80 | PS4 Pro 500 Million LE | PS5 | Xbox Series X
Steam: Godlike_RU | PSN: GoDlike_RU | XBL: GoDlike
Post Reply