Please help: issue with Momo racing to G27 ps3

Need help? Ask here and someone will help
User avatar
Posts: 235
Joined: Sat Jun 15, 2019 11:49 am
Location: South Africa

Re: Please help: issue with Momo racing to G27 ps3

Post by LoneWolf81 »

Ok do you by any chance have a windows pc to test it on ,just encase the wheel needs some special drivers/software to function normally. On a side note your adapter seems to be using a CP2102 that not actually recommended as its slower than the CP2104 this might not cause any issues im just putting it out there.

Seconly if you set GIMX to output curses can you see all the outputs in the window as you move the wheel and pedals, if you can its most likely a bad/intermittent usb cable try to test with another one.
Please Remember to Post your Log file in the support section , that way its easier and faster to start identifying the issue thus helping you to sort it out so you can enjoy GIMX :D .
User avatar
Posts: 5767
Joined: Wed Jul 06, 2011 7:01 am
Location: France

Re: Please help: issue with Momo racing to G27 ps3

Post by Matlo »


You have no button assigned, which is why it does not react to any button.

Try using the default config LogitechMomoRacing_G29.xml. It will work for a G27 emulation. You may need to replace the Dualshock 3 button bindings (joystick name = "Sony Computer Entertainment Wireless Controller") with keyboard keys, using gimx-config.
GIMX creator Donate Shop
Posts: 16
Joined: Fri Jul 10, 2020 3:18 pm

RESOLVED: issue with Momo racing to G27 ps3

Post by car1 »

Hi again peeps, my problem has been resolved!!! Thank you so much (lone wolf, Kaiba, Matlo) for your help.... I was so discouraged and fed up that I was starting to give up.

Anyway, to explain what I did and reply to your suggestions:

1- I installed JSTEST to verify that my ubuntu machine isn't faulty and is able to detect my steering and rumble pad >>> no problems found, they all responded perfectly, so I ruled that out. I was pleasantly surprised to see that my momo pedals and wheel are super precise and incremental (for a 2005 device no less)!

2- I once again combined my rumblepad with my momo and re-made / saved another config (different name on the xml file). All the buttons, expect for R2 and L2 were assigned on the rumblepad (R2 and L2 were assigned on the steering paddle shifters), and I assigned the 3 axis for the wheel, gas and brake.

***Important side note: I found a workaround with the glitch I mentioned earlier. Basically, when I'm assigning the gas and brake axis in GIMX config, after I click "auto detect", then press & release the pedal, then click "apply", a blank window appears and stays there until I press the ESC key. If I do that, an error message will appear saying that it was unsuccessful, although the setting registers (but really did not assign it). The workaround was that when the window appears I would firstly re-press and release the pedal before pressing the ESC key.... this would say a different message, something like "re-calibrated the pedal and added to library". When that message appears, the pedals are assigned.***

***Matlo, the G29 config did not work for me, that is why I manually created a new config.***

3- Ok, annoying and stupid technicality: the PS3 responds to GIMX when I plug the usb end to port 2. I wasted a lot of time because I used port 1 instead.

4-The sequence order that worked for me was (for f1 2014):
A) enter the game with DS3 controller and stay on the menu (just before entering the driving controls submenu),
B) Turn off the DS3. The game will ask to plug in a controller.
C) plug the momo to the pc (wait for the cycling then turn wheel all the way to the opposite end and release), then the rumblepad,
D) plug the GIMX adapter end to PC, then the usb end to PS3 (port 2),
E) launch GIMX and select the xml file then run it >>> The PS3 responds, and I am able to drive the car with zero issues.

So there you have it. Once I successfully try this technique with another brand steering wheel that I will eventually acquire later on, I will share the knowledge in this forum.

On a final note: when I run GIMX, I get 5 error messages, which are like:
"no macros enabled for momo and rumblepad" , "default spring return disabled", "force feedback disabled", among others. I can provide a log for this but wondering what these mean and why is it happening.... actually my force feedback isn't working well because although the wheel shakes when supposed to, it does not actively push back against my turning force (but returns slowly to the center).

Post Reply