Page 1 of 1

T300 without feedback

Posted: Wed Jun 08, 2022 4:29 pm
by sayser
hello everyone! why is there no force feedback at all on thrustmaster T300? the configuration chose Dualshock4_T300_PS4 UPD:edited the configuration file and added the following:
<force_feedback>
<device type="joystick" id="0" name="Thrustmaster T300RS Racing Wheel"/>
<g29_correction min_gain="20" range_start="4000" range_end="10000"/>
<gain rumble="100" constant="100" spring="100" damper="100"/>
</force_feedback>
Force feedback appeared, but gimx-launcher swears at the error: bad element name: g29_correction
Another question is why there are no configurations on raspberry Dualshock4_T300RS_PS4.xml how is it in windows?

Re: T300 without feedback

Posted: Thu Jun 09, 2022 4:17 pm
by kacklappen23
The T300 emulator does not support ffb. You need to use G29_PS4 if you want ffb.

The G29_Correction thing is only needed for a modified GIMX version one user created to stop oscillation around center. A normal GIMX build will throw an error. It also breaks the config and check functions.

Re: T300 without feedback

Posted: Thu Jun 09, 2022 5:03 pm
by sayser
thank you for the answer! I've already tried G29_PS4, and I don't have a force feedback, and the dead zone is very small, I attached a video: https://youtu.be/xtu-hnadi6c. Another problem, the pedals are connected to the base directly, but gimx does not define them as a joystick with a mouse

Re: T300 without feedback

Posted: Wed Jun 15, 2022 1:20 am
by kaiba_seto2004
Please post the log file on pastebin and add the link into your post.