Hyperion vs. GIMX on Raspberry Pi

Need help? Ask here and someone will help
Post Reply
mav2010
Posts: 2
Joined: Thu Sep 29, 2022 1:51 pm

Hyperion vs. GIMX on Raspberry Pi

Post by mav2010 »

Hi all,

I have a weird issue running GIMX on a Raspberry Pi with a Logitech G920, connected to a PS4.

Let me start by saying that running only GIMX on either a Raspberry Pi 4 or Zero W works wonderful. So I am not per se plagued by the known USB lag issues.

However, I am trying to run Hyperion (basically a custom built Ambilight) on the same Pi. The TV picture is channeled into the Pi by a USB Video grabber. Again: running Hyperian by itself - no issue. The moment I run both, the key presses become a bit random (sometimes key presses are swallowed, sometimes randon key presses are added) and force feedback is basically completely gone. The second I stop Hyperian, the force feedback works again and it even repeats the last few seconds of missing feedback, as if it was stuck somehwere.

I have tried on my Pi 4 and on my Pi Zero W various operating systems (mainly bullseye and buster based) and various Hyperian and GIMX versions. It appears to be a conflict between GIMX and the V4L2 driver that Hyperian is using for the USB grabber.

Any idea how to tackle this? I could really need a nudge in the right direction?

Thanks a lot!
mav2010
Posts: 2
Joined: Thu Sep 29, 2022 1:51 pm

Re: Hyperion vs. GIMX on Raspberry Pi

Post by mav2010 »

I can actually (kind of) answer my own question. I borrowed a Raspberry Pi 2B and to my surprise the Hyperion / GIMX combination immediately worked! So now I understand why the RPi support is considered experimental…

So whatever causes the issue, it apparently only affects the Zero W and the Pi4, not the 2B… 😳
User avatar
ckaiycool
Posts: 373
Joined: Thu Jul 10, 2014 8:16 pm
Location: Sweden

Re: Hyperion vs. GIMX on Raspberry Pi

Post by ckaiycool »

Nice investigating :D

You might have helped others from the headache with that.
Post Reply