DIY Fail!

Need help? Ask here and someone will help
Wilko159
Posts: 6
Joined: Thu Mar 11, 2021 7:20 am

DIY Fail!

Post by Wilko159 »

Hi all,
I've created a DIY gimx adapter using the following parts:

ATmega32U4:
https://www.ebay.co.uk/itm/323935195221

CP2102
https://www.ebay.co.uk/itm/283433187691




edit: I don't seem to be able to upload pictures either so see these two links
https://photos.app.goo.gl/ZJ8tTsheyi2Z1wn47
https://photos.app.goo.gl/yPhDrvBbuvimAj7w6

I've been able to load firmware without issue, but when I connect everything up I get an error:
"Error: failed to read packet header from the GIMX adapter"
I've rewired several times, tried swapping rx/tx but I get the same error repeatedly.

I've obviously done something fundamentally wrong, is it a hardware compatibility issue or is it something I've done?

See the log here:
https://pastebin.com/8eMEkcb3
User avatar
LoneWolf81
Posts: 228
Joined: Sat Jun 15, 2019 11:49 am
Location: South Africa

Re: DIY Fail!

Post by LoneWolf81 »

Hi

Just to confirm when you press start is the console powered up as it can give that error when you try and run it before the adapter is powered from the console side.

Have you tried a different cable between the adapter and console your soldering looks good to me.
Please Remember to Post your Log file in the support section , that way its easier and faster to start identifying the issue thus helping you to sort it out so you can enjoy GIMX :D .
Wilko159
Posts: 6
Joined: Thu Mar 11, 2021 7:20 am

Re: DIY Fail!

Post by Wilko159 »

Hi,
The console is definitely powered up and I've tried a few different leads.
They are definitely data cables also.

When I plug the adapter into my rig PC and open gimx I get the "Failed to read firmware type" error
It will still allow me to update the firmware, which it does successfully but the error still occurs.
Should I be using a different tool to update the firmware perhaps?

https://photos.app.goo.gl/mStrsJgxhLP8MxwU7

Thanks for the help!
User avatar
LoneWolf81
Posts: 228
Joined: Sat Jun 15, 2019 11:49 am
Location: South Africa

Re: DIY Fail!

Post by LoneWolf81 »

Try installing this driver for the CP2102

https://www.silabs.com/documents/public ... Driver.zip

If that fails to work I would suggest you try a live linux distro to test then we can isolate if its a windows issue or the maybe the serial board is faulty
Please Remember to Post your Log file in the support section , that way its easier and faster to start identifying the issue thus helping you to sort it out so you can enjoy GIMX :D .
Wilko159
Posts: 6
Joined: Thu Mar 11, 2021 7:20 am

Re: DIY Fail!

Post by Wilko159 »

Thanks, the drivers didn't help.
I tried running a USB based ubuntu but I don' know much about linux and couldn't get gimx installed.
User avatar
LoneWolf81
Posts: 228
Joined: Sat Jun 15, 2019 11:49 am
Location: South Africa

Re: DIY Fail!

Post by LoneWolf81 »

Just want to confirm the firmware loading method you are using, are you doing it from the help menu and choosing update firmware or are you using another method.
Please Remember to Post your Log file in the support section , that way its easier and faster to start identifying the issue thus helping you to sort it out so you can enjoy GIMX :D .
Wilko159
Posts: 6
Joined: Thu Mar 11, 2021 7:20 am

Re: DIY Fail!

Post by Wilko159 »

I'm loading via the help-update firmware method. (which tells me that the firmware loaded successfully)
I'm wondering if I should try another method?

I've also tried a different usb-uart board with exactly the same outcome
Wilko159
Posts: 6
Joined: Thu Mar 11, 2021 7:20 am

Re: DIY Fail!

Post by Wilko159 »

Would just like to say that I've resolved this issue by purchasing a pre made adapter. Worked perfectly straight away so I must have had an issue with one of the boards.
User avatar
GoDlike
Posts: 1068
Joined: Thu Apr 28, 2016 12:47 pm
Location: Poland

Re: DIY Fail!

Post by GoDlike »

Im glad you resolved the issue. Have fun with GIMX!
My hardware: PS3 Slim CFW 4.80 | PS4 Pro 500 Million LE | PS5 | Xbox Series X
Steam: Godlike_RU | PSN: GoDlike_RU | XBL: GoDlike
Jannick
Posts: 3
Joined: Thu Apr 29, 2021 8:45 am

Re: DIY Fail!

Post by Jannick »

Wilko159 wrote:
Fri Mar 26, 2021 4:09 pm
Would just like to say that I've resolved this issue by purchasing a pre made adapter. Worked perfectly straight away so I must have had an issue with one of the boards.
That's great, games sometimes may give us the pulse and energy to do things.
Last edited by Jannick on Thu May 27, 2021 8:04 am, edited 1 time in total.
Post Reply