Page 1 of 1

Controls don't work on Battlefield 5 on PS4

Posted: Sun Feb 21, 2021 6:42 am
by akthrowaway
SOLVED!! I'm so dumb :lol:
Found it here: http s://


I am a super old guy gamer who has trouble with gamepads. I'm also an engineer and noticed that I just happened to have all the hardware require to get this working. So I went through the tutorial and everything worked like a dream. All the keys in the PlayStation menu do exactly what they should. But when I open battlefield 5, the only key that works is the PS button. now my controller registered as a ts400 so I thought maybe that was it. I went out and picked up a used dualshock 4 controller and this one registers as a dualshock controller so no problems there. But same problem, no controls when I open the game. I can go back to the home screen and all the controls work again. I tried to open the game and then shut down the controller and then start gimx, but the screen locks out with a message to reconnect wireless controller. I can't find a single browser link that relates to this and there were no other posts here on support that reference this. Can anyone help? Thanks so much!