dpkg: Fehler beim Bearbeiten des Archivs /home/pi/Downloads/gimx_8.0-1_armhf.deb (--unpack): Versuch, »/usr/bin/bdaddr«

Need help? Ask here and someone will help
Post Reply
FO2562
Posts: 1
Joined: Sun Jan 10, 2021 9:29 am

dpkg: Fehler beim Bearbeiten des Archivs /home/pi/Downloads/gimx_8.0-1_armhf.deb (--unpack): Versuch, »/usr/bin/bdaddr«

Post by FO2562 »

Hello GIMX'ers
I have a problem installing the package: gimx_8.0-1_armhf.deb

Code: Select all

Contents of the Downloads/ directory
pi@raspberrypi:~/Downloads $ ls -lA
total 3416
-rw-r--r-- 1 pi pi 562992 Jan 10 10:05 gimx_8.0-1_armhf.deb
-rw-r--r-- 1 pi pi 2930282 Dec 27 20:30 steam_latest.deb

Code: Select all

pi@raspberrypi:~/downloads $ sudo apt --ignore-missing install ./* && sudo apt --fix-broken install ./*
Package lists are read... Done
Dependency tree is built.       
Status information is read.... Done
Note: "gimx" is selected instead of "./gimx_8.0-1_armhf.deb".
Note: "steam-launcher" is selected instead of "./steam_latest.deb".
The following NEW packages will be installed:
  gimx steam-launcher
0 updated, 2 reinstalled, 0 to remove and 65 not updated.
8 not completely installed or removed.
There are still 0 B of 3,493 kB of archives to be downloaded.
After this operation, 5,173 kB of additional disk space is used.
Fetch:1 /home/pi/Downloads/steam_latest.deb steam-launcher all 1:1.0.0.67 [2,930 kB]
Get:2 /home/pi/Downloads/gimx_8.0-1_armhf.deb gimx armhf 8.0-1 [563 kB]
(Read database ... 169179 files and directories are currently installed).
Preparation for unpacking .../pi/Downloads/steam_latest.deb ...
Unpacking steam-launcher (1:1.0.0.67) ...
dpkg: Error processing archive /home/pi/Downloads/steam_latest.deb (--unpack):
 Attempt to overwrite "/lib/udev/rules.d/60-steam-input.rules" which is also in package steamlink 1.0.7
Preparing to unpack .../downloads/gimx_8.0-1_armhf.deb ...
Unpacking gimx (8.0-1) ...
dpkg: Error while processing archive /home/pi/Downloads/gimx_8.0-1_armhf.deb (--unpack):
 Attempt to overwrite "/usr/bin/bdaddr" which is also in package bluez 5.50-1.2~deb10u1+rpt2
dpkg-deb: error: "insert" subprocess was killed by signal (data transfer interrupted (broken pipe))
Errors occurred while editing:
 /home/pi/Downloads/steam_latest.deb
 /home/pi/Downloads/gimx_8.0-1_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

The PC has the following specification:

Code: Select all

pi@raspberrypi:~/Downloads $ uname -a
Linux raspberrypi 5.4.79-v7l+ #1373 SMP Mon Nov 23 13:27:40 GMT 2020 armv7l GNU/Linux

pi@raspberrypi:~/Downloads $ cat /proc/cpuinfo
processor	: 0
model name	: ARMv7 Processor rev 3 (v7l)
BogoMIPS	: 108.00
Features	: half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32 
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x0
CPU part	: 0xd08
CPU revision	: 3

processor	: 1
model name	: ARMv7 Processor rev 3 (v7l)
BogoMIPS	: 108.00
Features	: half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32 
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x0
CPU part	: 0xd08
CPU revision	: 3

processor	: 2
model name	: ARMv7 Processor rev 3 (v7l)
BogoMIPS	: 108.00
Features	: half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32 
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x0
CPU part	: 0xd08
CPU revision	: 3

processor	: 3
model name	: ARMv7 Processor rev 3 (v7l)
BogoMIPS	: 108.00
Features	: half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32 
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x0
CPU part	: 0xd08
CPU revision	: 3

Hardware	: BCM2711
Revision	: c03130
Serial		: 10000000dc60df51
Model		: Raspberry Pi 400 Rev 1.0
I can't find a solution at the moment. Who of you has experience and support me? Thanks!
User avatar
LoneWolf81
Posts: 218
Joined: Sat Jun 15, 2019 11:49 am
Location: South Africa

Re: dpkg: Fehler beim Bearbeiten des Archivs /home/pi/Downloads/gimx_8.0-1_armhf.deb (--unpack): Versuch, »/usr/bin/bda

Post by LoneWolf81 »

Hi

Run the following commands

Code: Select all

sudo dpkg --force-overwrite -i gimx_8.0-1_armhf.deb

sudo apt-get install -f
Please Remember to Post your Log file in the support section , that way its easier and faster to start identifying the issue thus helping you to sort it out so you can enjoy GIMX :D .
Post Reply