No Dualshock 4 controller was found on USB ports

Need help? Ask here and someone will help
Post Reply
mattydiah
Posts: 11
Joined: Fri Nov 17, 2017 4:31 pm

No Dualshock 4 controller was found on USB ports

Post by mattydiah »

Hi,

I am using a homemade GIMX adapter that has been working great for more than a year now. Suddenly, when I try to use gimx-launcher, I am getting an error that says "No Dualshock 4 controller was found on USB ports". I know my controller works because hitting the playstation button brings up Steam.

I am on GIMX 8.0 x86_64, with the newest version of USBDK, and the adapter is on G29PS4.hex firmware

I am using it to interface a T300RS and Fanatec pedals with a PS4 for GT Sport

User avatar
LoneWolf81
Posts: 120
Joined: Sat Jun 15, 2019 11:49 am
Location: South Africa

Re: No Dualshock 4 controller was found on USB ports

Post by LoneWolf81 »

Hi

Please add a log file
Please Remember to Post your Log file in the support section , that way its easier and faster to start identifying the issue thus helping you to sort it out so you can enjoy GIMX :D .

mattydiah
Posts: 11
Joined: Fri Nov 17, 2017 4:31 pm

Re: No Dualshock 4 controller was found on USB ports

Post by mattydiah »

Here it is
global option -l with value `log.txt'
global option -c with value `PS4_T300RS_Ferrari_F1_Fanatec Pedals.xml'
controller #1: option -p with value `COM4'
now reading arguments for controller #2
status flag is set
subpos flag is set
force_updates flag is set
auto-grab flag is set
GIMX 8.0 x86_64
Windows 10 (or later) x64
Kernel version: 10.0 (18363)
GIMX adapter detected, controller type is: G29 PS4.
Firmware version: 8.0
Reset sent to the GIMX adapter.
Current baudrate: 500000 bps.
Trying baudrate: 2000000 bps.
Trying baudrate: 1000000 bps.
Trying baudrate: 500000 bps.
Using baudrate: 500000 bps.
src/gusb.c:888 claim_device: libusb_open failed with error: Other error
src/gusb.c:888 claim_device: libusb_open failed with error: Other error
Error: No game controller was found on USB ports.
And here is "PS4_T300RS_Ferrari_F1_Fanatec Pedals.xml"
<?xml version="1.0" encoding="UTF-8"?>

-<root>


-<controller type="G29 PS4" dpi="0" id="1">


-<configuration id="1">

<trigger type="" id="" delay="0" switch_back="no" button_id="" name=""/>

<mouse_options_list/>

<intensity_list/>


-<button_map>


-<button id="abs_axis_8" label="">

<device type="joystick" id="0" name="Thrustmaster T300RS Racing Wheel"/>

<event type="button" id="5"/>

</button>


-<button id="abs_axis_7" label="">

<device type="joystick" id="0" name="Thrustmaster T300RS Racing Wheel"/>

<event type="button" id="4"/>

</button>


-<button id="abs_axis_9" label="">

<device type="joystick" id="0" name="Thrustmaster T300RS Racing Wheel"/>

<event type="button" id="11"/>

</button>


-<button id="abs_axis_10" label="">

<device type="joystick" id="0" name="Thrustmaster T300RS Racing Wheel"/>

<event type="button" id="3"/>

</button>


-<button id="abs_axis_14" label="">

<device type="joystick" id="0" name="Thrustmaster T300RS Racing Wheel"/>

<event type="button" id="8"/>

</button>


-<button id="abs_axis_13" label="">

<device type="joystick" id="0" name="Thrustmaster T300RS Racing Wheel"/>

<event type="button" id="9"/>

</button>


-<button id="abs_axis_2" label="">

<device type="joystick" id="0" name="Thrustmaster T300RS Racing Wheel"/>

<event type="button" id="12"/>

</button>


-<button id="abs_axis_1" label="">

<device type="joystick" id="0" name="Thrustmaster T300RS Racing Wheel"/>

<event type="button" id="7"/>

</button>


-<button id="abs_axis_0" label="">

<device type="joystick" id="0" name="Thrustmaster T300RS Racing Wheel"/>

<event type="button" id="6"/>

</button>


-<button id="abs_axis_6" label="">

<device type="joystick" id="0" name="Thrustmaster T300RS Racing Wheel"/>

<event type="button" id="15"/>

</button>


-<button id="abs_axis_4" label="">

<device type="joystick" id="0" name="Thrustmaster T300RS Racing Wheel"/>

<event type="button" id="13"/>

</button>


-<button id="abs_axis_3" label="">

<device type="joystick" id="0" name="Thrustmaster T300RS Racing Wheel"/>

<event type="button" id="16"/>

</button>


-<button id="abs_axis_5" label="">

<device type="joystick" id="0" name="Thrustmaster T300RS Racing Wheel"/>

<event type="button" id="14"/>

</button>


-<button id="abs_axis_11" label="">

<device type="joystick" id="0" name="Thrustmaster T300RS Racing Wheel"/>

<event type="button" id="0"/>

</button>


-<button id="abs_axis_12" label="">

<device type="joystick" id="0" name="Thrustmaster T300RS Racing Wheel"/>

<event type="button" id="1"/>

</button>

</button_map>


-<axis_map>


-<axis id="abs_axis_17" label="">

<device type="joystick" id="0" name="FANATEC CSL Elite Pedals LC"/>

<event type="axis" id="0" shape="" exponent="1.00" multiplier="0.008" dead_zone="0"/>

</axis>


-<axis id="abs_axis_18" label="">

<device type="joystick" id="0" name="FANATEC CSL Elite Pedals LC"/>

<event type="axis" id="1" shape="" exponent="1.00" multiplier="0.008" dead_zone="0"/>

</axis>


-<axis id="abs_axis_19" label="">

<device type="joystick" id="0" name="FANATEC CSL Elite Pedals LC"/>

<event type="axis" id="2" shape="" exponent="1.00" multiplier="0.008" dead_zone="0"/>

</axis>


-<axis id="rel_axis_0" label="">

<device type="joystick" id="0" name="Thrustmaster T300RS Racing Wheel"/>

<event type="axis" id="0" shape="" exponent="1.00" multiplier="0.0039" dead_zone="0"/>

</axis>

</axis_map>


-<joystick_corrections_list>


-<correction high_coef="8191" high_value="-32768" low_coef="0" low_value="-32768">

<device type="joystick" id="0" name="FANATEC CSL Elite Pedals LC"/>

<event type="axis" id="0"/>

</correction>


-<correction high_coef="8191" high_value="-32768" low_coef="0" low_value="-32768">

<device type="joystick" id="0" name="FANATEC CSL Elite Pedals LC"/>

<event type="axis" id="1"/>

</correction>


-<correction high_coef="8191" high_value="-32768" low_coef="0" low_value="-32768">

<device type="joystick" id="0" name="FANATEC CSL Elite Pedals LC"/>

<event type="axis" id="2"/>

</correction>

</joystick_corrections_list>

</configuration>

</controller>

</root>

User avatar
LoneWolf81
Posts: 120
Joined: Sat Jun 15, 2019 11:49 am
Location: South Africa

Re: No Dualshock 4 controller was found on USB ports

Post by LoneWolf81 »

I want you to remove GIMX and USBDK and reboot afterwards reinstall GIMX and reboot again then test it. Are you using any usb hubs ?
Please Remember to Post your Log file in the support section , that way its easier and faster to start identifying the issue thus helping you to sort it out so you can enjoy GIMX :D .

Cybereu
Posts: 145
Joined: Sun Jul 10, 2011 1:10 pm

Re: No Dualshock 4 controller was found on USB ports

Post by Cybereu »

Most of these situations are due bad/broken USB cable, please try others one and without any usb hub.

mattydiah
Posts: 11
Joined: Fri Nov 17, 2017 4:31 pm

Re: No Dualshock 4 controller was found on USB ports

Post by mattydiah »

I am using hubs but the removal of Gimx and Uzbek and reinstalling gimx fixed it. Thanks!

User avatar
LoneWolf81
Posts: 120
Joined: Sat Jun 15, 2019 11:49 am
Location: South Africa

Re: No Dualshock 4 controller was found on USB ports

Post by LoneWolf81 »

Awesome glad to hear its sorted :D
Please Remember to Post your Log file in the support section , that way its easier and faster to start identifying the issue thus helping you to sort it out so you can enjoy GIMX :D .

Post Reply