Raspberry pi start at boot not working

Need help? Ask here and someone will help
Josh
Posts: 46
Joined: Thu Oct 18, 2018 10:36 pm

Raspberry pi start at boot not working

Post by Josh » Wed Apr 24, 2019 4:13 am

I just recently got gimx to work on raspberry pi by using the GUI but I would rather not have a monitor sitting on my floor in my basement, so I tried going for the auto start gimx at boot as seen on the raspberry pi gimx wiki page. So I copied and pasted everything over (keeping in mind to change what was necessary) and it all seemed to look ok I guess, but then when my raspberry pi rebooted, nothing happened, it just went to its normal screen I.e gimx didn’t start :cry: ... please help thanks
Also it doesn’t say what does or doesn’t need to be plugged in when you boot up so I just plugged everything in like a normal gimx boot up.

User avatar
Matlo
Posts: 5351
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: Raspberry pi start at boot not working

Post by Matlo » Wed Apr 24, 2019 7:44 am

Fixed?
GIMX creator Donate Shop

Josh
Posts: 46
Joined: Thu Oct 18, 2018 10:36 pm

Re: Raspberry pi start at boot not working

Post by Josh » Wed Apr 24, 2019 1:08 pm

What do you mean?

User avatar
kaiba_seto2004
Posts: 324
Joined: Sat Jul 15, 2017 9:15 am

Re: Raspberry pi start at boot not working

Post by kaiba_seto2004 » Thu Apr 25, 2019 8:42 am

Did you fix it yourself? He means that.

Btw, if you want gimx run on boot, you need to create a service with root right. Please refer guide here:
PS4 enthusiast.

Josh
Posts: 46
Joined: Thu Oct 18, 2018 10:36 pm

Re: Raspberry pi start at boot not working

Post by Josh » Thu Apr 25, 2019 12:42 pm

So far I have not fixed it. The page that you have linked is the page that I referenced off of, I did everything it said but when I plug in the power for my raspberry pi gimx doesn’t seem to start, the controller just turns off and then on and then off again, however when I look at cpu usage a task named gimx is always at the top of the cpu usage at around 4% but it says the program isn’t running (greyed out). Also I don’t know what it means for the blink.py script when it says put it in pi user crontab.

User avatar
kaiba_seto2004
Posts: 324
Joined: Sat Jul 15, 2017 9:15 am

Re: Raspberry pi start at boot not working

Post by kaiba_seto2004 » Thu Apr 25, 2019 5:13 pm

Well with this method gimx works in console environment, not desktop or X mode. So for testing, you need to connect to Rpi from SSH using its IP.
About crontab, it's not necessary. Just to show you gimx is running or not. Btw, you can imagine crontab like task scheduler in Windows.
PS4 enthusiast.

Cybereu
Posts: 128
Joined: Sun Jul 10, 2011 1:10 pm

Re: Raspberry pi start at boot not working

Post by Cybereu » Thu Apr 25, 2019 10:55 pm

I think you can start a script on desktop LXDE startup with :


With text editor:
1 - Navigate to /home/pi
2- Edit .bashrc
If you cant find .bashrc press crtl + h, maybe its hidden
3- add: gimx -p /dev/ttyUSB0 -c YOUR_CONFIG_FILE_HERE.xml --force-updates --subpos
4 - Save

On terminal:
1- sudo nano /home/pi/.bashrc
2- gimx -p /dev/ttyUSB0 -c YOUR_CONFIG_FILE_HERE.xml --force-updates --subpos

Change YOUR_CONFIG_FILE_HERE.xml for config file that is in /home/pi/.gimx/config folder

Josh
Posts: 46
Joined: Thu Oct 18, 2018 10:36 pm

Re: Raspberry pi start at boot not working

Post by Josh » Fri Apr 26, 2019 1:40 am

To Kaia, so your saying that you don’t know a way to start a program through its “normal boot” process per say but the way I was talking about was a way to start gimx through its terminal form i.e it’s non GUI form. Ok I get that but would that still mean that it would work, or is there something I have to do to get it into console form. Also why (and how) do I ssh into the raspberry pi, why do I need to remotely activate gimx, I thought this was supposed to auto start when my raspberry booted up? For crontab I just wanted a way to tell for sure if gimx was running to tell if it was me plugging in something wrong. Thanks for the help

Josh
Posts: 46
Joined: Thu Oct 18, 2018 10:36 pm

Re: Raspberry pi start at boot not working

Post by Josh » Fri Apr 26, 2019 1:45 am

To cybereu, your saying that there is a way to auto start gimx in desktop mode correct? I’m assuming both of the scripts you have are the same but are getting to the point in a different way. Either way thanks for the input I will try this later tonight.

Josh
Posts: 46
Joined: Thu Oct 18, 2018 10:36 pm

Re: Raspberry pi start at boot not working

Post by Josh » Fri Apr 26, 2019 2:59 am

Ok, upon trying your method I am confused as to where i am supposed to put your text seeing as there is already a lot of text in the file and i dont think im just supposed to erase everything.

EDIT: ok I’m assuming I put it after everything, but to test is I tried just putting it in terminal but I get an error because it’s trying to access my config file through root, it says could not parse file /root/.gimx/config/(my config).xml: no such file or directory. I tried putting the path to get to my config but no matter what I try it always tries to go through root first. :? I can post a picture or pastebin if needed

Post Reply