New PC GIMX user with issues (half working)

Need help? Ask here and someone will help
Post Reply
anton_Chez
Posts: 2
Joined: Mon Oct 15, 2018 6:53 am

New PC GIMX user with issues (half working)

Post by anton_Chez » Mon Oct 15, 2018 7:07 am

Hi guys,

New (and extremely frustrated) GIMX user here. Adapter just arrived here in Australia and I am trying to get it all working as I've heard people describe it. For me, it's been a few hours of trial and error and head banging.

I have the adapter installed, recognised in the PC, my OSW and HE pedals, shifter and handbrake are all recognised and assigned in the GIMX software. I have the G27 PC firmware installed as suggested, and I have run the Check and everything seems to be OK! I have the Logitech profiler installed, and the all pedals and the steering wheel all show up with inputs on the display. I have a G27 displayed in Devices and Printers in Windows, too. So all seems well. Until you test the games.

V-Rally binds, with no ill effects in the menus. But the FFB when in the car is non existent until it tries to detach your hands from your arms. It's super erratic and very un-unsable. I assigned the HE shifter in the GIMX software too, but in game it appears as if it's assigning its own buttons, not linked to the G27. Anyway, onto the others.

WRC 7 and SRLE are both being affected in menus. Pressing the arrow keys on the keyboard to navigate always ends up being affected by the pedals. When you press the pedals, the cursor select on the menu moves with it. It's un-usable. This happened before the GIMX which comes down to poor support (hence the GIMX) but I am able to assign axis and buttons in WRC 7 now, which I was absolutely unable to before. So all pedals and steering wheel are calibrated. Yet it's still acting like the HE Pro's are connected without being assigned to the G27 hardware. It's super weird and I am about to give up with it. You manage to get in game, and the camera is outside the car, like a side on replay camera view, the steering wheel is pulling to the left, it's just all over the place. SLRE won't even let me get into the main menu, because as per WRC 7 the menus are affected by something in the hardware. The up button refuses to work, and I guess it's because of the same issue in WRC 7.

I would have thought that having the G27 be recognised by the PC AND the games, would have disabled the weird inputs that all the high end hardware tend to transmit to the games. It appears I was wrong. If I disable the HE pedals device in Windows in the hope to remove these issues, won't I lose the pedals? None of it makes sense and I am this close to eBaying the adapter and forget it and any of the games that require it even exist. People have this working and I just cannot see how.

ANY help is appreciated. I like off road games and it's a shame that most of them are half baked efforts that leave users with anything more than a $300 setup out in the cold.

User avatar
Matlo
Posts: 5040
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: New PC GIMX user with issues (half working)

Post by Matlo » Mon Oct 15, 2018 7:30 am

Hello,

Try inverting the force direction: open your config with gimx-config, Go to the "Overall > Force Feedback Tweaks" panel, click on "Auto-detect", move your wheel axis to make it detect your wheel, check "Invert direction", and save.

For further help, please provide a log file as requested in forum rules: viewtopic.php?f=5&t=691
And make sure to play a dozen of seconds while generating the log file.
GIMX creator Donate Shop

anton_Chez
Posts: 2
Joined: Mon Oct 15, 2018 6:53 am

Re: New PC GIMX user with issues (half working)

Post by anton_Chez » Mon Oct 15, 2018 8:50 am

Thank you Matlo, I will give that a try and report back. I was looking for options to invert, I couldn't find any but this might sort out the issue for me. I have a league race now but I will be back after that to test what you have suggested. Many thanks for a quick suggestion. Appreciate it :)

Post Reply