dependency problems prevent configuration of gimx 7.9.1

Need help? Ask here and someone will help
Post Reply
Karoshii
Posts: 4
Joined: Wed Jan 06, 2016 5:17 am

dependency problems prevent configuration of gimx 7.9.1

Post by Karoshii » Sat Sep 08, 2018 11:00 am

Hi,

I would like to seek help on installing the latest version of GIMX on my Rpi.
I followed the steps on the Wiki but I still get the following errors:

GIMX installation

Code: Select all

wget https://gimx.fr/download/gimx-raspbian -O gimx.deb
sudo dpkg -i gimx.deb
Got a the dependency errors.

Code: Select all

pi@raspberrypi:~ $ sudo dpkg -i gimx.deb
(Reading database ... 128438 files and directories currently installed.)
Preparing to unpack gimx.deb ...
Unpacking gimx (7.9-1) over (7.9-1) ...
dpkg: dependency problems prevent configuration of gimx:
 gimx depends on libncursesw5 (>= 6); however:
  Version of libncursesw5:armhf on system is 5.9+20140913-1+deb8u3.
 gimx depends on libstdc++6 (>= 5.2); however:
  Version of libstdc++6:armhf on system is 4.9.2-10+deb8u1.
 gimx depends on libtinfo5 (>= 6); however:
  Version of libtinfo5:armhf on system is 5.9+20140913-1+deb8u3.
 gimx depends on libwxbase3.0-0v5 (>= 3.0.2+dfsg); however:
  Package libwxbase3.0-0v5 is not installed.
 gimx depends on libwxgtk3.0-0v5 (>= 3.0.2+dfsg); however:
  Package libwxgtk3.0-0v5 is not installed.

dpkg: error processing package gimx (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-6) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.58) ...
Errors were encountered while processing:
 gimx
pi@raspberrypi:~ $
I tried all the upgrade and update found on the wiki, and even tried to force update of my entire system.

Code: Select all

sudo apt-get update && sudo apt-get upgrade
sudo apt-get -f install


I tried to downgrade my installation just to make it work an upon trial and error I was able to get version 6.4 to work.

Code: Select all

pi@raspberrypi:~ $ sudo dpkg -i gimx.deb
dpkg: warning: downgrading gimx from 6.11-1 to 6.4-1
(Reading database ... 128431 files and directories currently installed.)
Preparing to unpack gimx.deb ...
Unpacking gimx (6.4-1) over (6.11-1) ...
Setting up gimx (6.4-1) ...
Processing triggers for gnome-menus (3.13.3-6) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.58) ...
pi@raspberrypi:~ $

Here is my OS version:

Code: Select all

pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.1.21+ #873 Mon Apr 11 18:00:37 BST 2016 armv6l GNU/Linux
Sources:

Code: Select all

sudo nano /etc/apt/sources.list
deb http://mirrordirector.raspbian.org/raspbian jessie main firmware

Thanks to anyone who can help.

User avatar
Matlo
Posts: 5041
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: dependency problems prevent configuration of gimx 7.9.1

Post by Matlo » Sat Sep 08, 2018 1:53 pm

Hello,

Raspbian Jessie is no more supported. Please upgrade to Raspbian Stretch.
GIMX creator Donate Shop

Karoshii
Posts: 4
Joined: Wed Jan 06, 2016 5:17 am

Re: dependency problems prevent configuration of gimx 7.9.1

Post by Karoshii » Sun Sep 09, 2018 3:10 pm

Hi Matlo,

Thanks! I will find some tutorials on how to upgrade from Jessie to Stretch an post back here if successful or if there are issues.
Its been a while since I updated so it is a big leap on versions.

User avatar
kaiba_seto2004
Posts: 200
Joined: Sat Jul 15, 2017 9:15 am

Re: dependency problems prevent configuration of gimx 7.9.1

Post by kaiba_seto2004 » Sun Sep 09, 2018 5:00 pm

There are some pre-built images. You can just flash it and install gimx then.
PS4 enthusiast.

Karoshii
Posts: 4
Joined: Wed Jan 06, 2016 5:17 am

Re: dependency problems prevent configuration of gimx 7.9.1

Post by Karoshii » Wed Sep 12, 2018 6:54 am

Upgrading an outdated version of Raspbian Jessie was a bad idea.
Thanks to kaiba_seto2004 for the advice.

What I did that worked was to Flash the SD card with the latest version of Stretch.
after flashing updated that using

Code: Select all

sudo apt-get update && sudo apt-get upgrade
sudo rpi-update
unfortunately all the settings mentioned on the WiKi had to be re-applied.
It would still be faster than upgrading though, and a fresh install is always nice.

i had encountered a dependency error when installing GIMX but the OS suggested a command that fixed it.
now running the latest GIMX on the latest Raspbian OS.

Post Reply