Buttons not working

Need help? Ask here and someone will help
Post Reply
DevvMan
Posts: 7
Joined: Tue Jun 19, 2018 10:26 pm

Buttons not working

Post by DevvMan » Tue Jun 19, 2018 10:41 pm

Hi :D ,
I have a problem, I have a mouse with programmable keys on the side and I use it along with my keyboard. I play rainbow six siege on ps4.
Heres my config that I use https://ibb.co/gvceXy]

I have "q" and "e" bound to l3 and r3, and I also have "page up" and "v" bound to L3 and R3.
But whenever I want to peek around corners using "q" or "e" It acts as id "q" is L1 and "e" is R1 which makes no sense to me. I don't have them bound to those keys but they still acts as if they are L1 and R1. My "page up" and "v" works for L3 and R3 . In rainbow six siege If you aim down sight and press L3 or R3 you lean left and right. But whenever I hold right click on my mouse and press "Page up" and "v" it wont lean left and right. "Page up" and "V" are programmed keys that I placed on my mouse.

I use my mouse like this on pc games and it works find but im having problems with this adapter and its really frustrating.
Any ideas?

FYI My mouse is a utech smart venus btw

User avatar
kaiba_seto2004
Posts: 187
Joined: Sat Jul 15, 2017 9:15 am

Re: Buttons not working

Post by kaiba_seto2004 » Wed Jun 20, 2018 7:30 am

I think this maybe relate to profile trigger. I need your log file to make sure
viewtopic.php?f=5&t=691
PS4 enthusiast.

DevvMan
Posts: 7
Joined: Tue Jun 19, 2018 10:26 pm

Re: Buttons not working

Post by DevvMan » Wed Jun 20, 2018 6:55 pm

Here is the link to my Log file. I tried to replicate the problem it should be near the end. https://pastebin.com/6n3Ay8aG

User avatar
Cybereu
Posts: 110
Joined: Sun Jul 10, 2011 1:10 pm

Re: Buttons not working

Post by Cybereu » Wed Jun 20, 2018 7:43 pm

Could you post your config file ?
Linux 4ev

DevvMan
Posts: 7
Joined: Tue Jun 19, 2018 10:26 pm

Re: Buttons not working

Post by DevvMan » Wed Jun 20, 2018 8:27 pm

I posted it in my 1st comment. Its a link to an image of my config

DevvMan
Posts: 7
Joined: Tue Jun 19, 2018 10:26 pm

Re: Buttons not working

Post by DevvMan » Wed Jun 20, 2018 8:35 pm

I just understood you wanted the file. I'm not sure how to give it to you so i uploaded it to uploadfiles heres the link https://ufile.io/jlrlx

User avatar
GoDlike
Posts: 473
Joined: Thu Apr 28, 2016 12:47 pm
Location: Poland

Re: Buttons not working

Post by GoDlike » Wed Jun 20, 2018 8:52 pm

That log on pastebin is perfectly fine mate, just wait for kaiba_seto to reply ;)
My hardware: Xbox 360 S "Trinity" RGH | PS3 Slim CFW 4.80 | PS4 6.00 | Mouse: 8 years old Gigabyte M8000x :mrgreen:
My Steam: http://steamcommunity.com/id/Godlike_RU/ | PSN: GoDlike_RU

User avatar
kaiba_seto2004
Posts: 187
Joined: Sat Jul 15, 2017 9:15 am

Re: Buttons not working

Post by kaiba_seto2004 » Thu Jun 21, 2018 10:20 am

Due to your log file I see you got 4 profiles. In profile 2, "q" was binded to 2 buttons: L3, triangle and this will mess your game. "q" and "e" were also binded to "l1" and "r1" in profile 3 that's why.
So you need to reconfig your config with gimx-config, do remember to uncheck "Link controls" (this won't link buttons between configs)
Image

And one last thing, you'd better install gimx 64bit instead of 32bit because your windows is 64bit.
PS4 enthusiast.

DevvMan
Posts: 7
Joined: Tue Jun 19, 2018 10:26 pm

Re: Buttons not working

Post by DevvMan » Thu Jun 21, 2018 6:42 pm

Ok thanks, It no longer acts as if I am pressing "L1" and "R1" when I press L3 and R3 but now whenever I aim in using right click and press q and e to lean I am stuck aiming and cannot get out of it no matter how many times I press right click. I have to restart the program to get out of it. Any ideas?

DevvMan
Posts: 7
Joined: Tue Jun 19, 2018 10:26 pm

Re: Buttons not working

Post by DevvMan » Thu Jun 21, 2018 8:16 pm

Never mind it works now. Thank you so much for your help!

Post Reply