Gimx adapter & Rpi3 model B

Need help? Ask here and someone will help
kamperkilla87
Posts: 90
Joined: Tue Mar 13, 2018 7:10 am

Re: Gimx adapter & Rpi3 model B

Post by kamperkilla87 » Sat Mar 24, 2018 10:03 pm

Ok I'll reinstall stretch, an gimx 7.2. Im confused why it work for you an not for me. Do download the gimx software you just double click as you mentioned before correct? The amrhf package? Then install it while being connected to the network. After it's installed is there anything else I have to do?

User avatar
Matlo
Posts: 5015
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: Gimx adapter & Rpi3 model B

Post by Matlo » Sat Mar 24, 2018 10:11 pm

Your installation seems correct.

I just made more tests. Sometimes I have to unplug and replug the adapter from/to the console. After doing this no problem happens until stopping GIMX.
GIMX creator Donate Shop

kamperkilla87
Posts: 90
Joined: Tue Mar 13, 2018 7:10 am

Re: Gimx adapter & Rpi3 model B

Post by kamperkilla87 » Sat Mar 24, 2018 10:13 pm

Do I update gimx with emuxbone file? I did do that, thought I was.supposed to. An maybe it's my configuration causing the problem. Can you send me to a working xml config that you know for sure works.

User avatar
Matlo
Posts: 5015
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: Gimx adapter & Rpi3 model B

Post by Matlo » Sat Mar 24, 2018 10:40 pm

There is no need to change the firmware. You only have to do it once. Once you clicked on Start in gimx-launcher, make sure to press the control that is mapped to the guide button.
GIMX creator Donate Shop

kamperkilla87
Posts: 90
Joined: Tue Mar 13, 2018 7:10 am

Re: Gimx adapter & Rpi3 model B

Post by kamperkilla87 » Sat Mar 24, 2018 11:07 pm

maybe its the config im trying to use. im just trying the xbox onepad config. guide button is mapped to thew number 8. after i press start in the gimx launcher i press 8 but nothing happens. do you have a xbox one config i can try? here is a log file of me starting the launcher while holding the number 8.

kamperkilla87
Posts: 90
Joined: Tue Mar 13, 2018 7:10 am

Re: Gimx adapter & Rpi3 model B

Post by kamperkilla87 » Sat Mar 24, 2018 11:07 pm

Code: Select all

global option -l with value `log.txt'
global option -c with value `XOnePadUsb.xml'
controller #1: option -p with value `/dev/ttyUSB0'
now reading arguments for controller #2
status flag is set
subpos flag is set
force_updates flag is set
GIMX 7.2 ARMv6
Raspbian GNU/Linux 9.1 (stretch)
Linux 4.9.59-v7+ #1047 SMP Sun Oct 29 12:19:23 GMT 2017 unknown
Bus 001 Device 004: ID 1b1c:1b3c Corsair 
Bus 001 Device 012: ID 0e6a:02c0 Megawin Technology Co., Ltd 
Bus 001 Device 008: ID 10c4:ea60 Cygnal Integrated Products, Inc. CP210x UART Bridge / myAVR mySmartUSB light
Bus 001 Device 006: ID 045e:02d1 Microsoft Corp. XBOX One Controller for Windows
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/5p, 480M
        |__ Port 1: Dev 3, If 0, Class=Vendor Specific Class, Driver=smsc95xx, 480M
        |__ Port 2: Dev 6, If 0, Class=Vendor Specific Class, Driver=xpad, 12M
        |__ Port 2: Dev 6, If 1, Class=Vendor Specific Class, Driver=, 12M
        |__ Port 2: Dev 6, If 2, Class=Vendor Specific Class, Driver=, 12M
        |__ Port 3: Dev 8, If 0, Class=Vendor Specific Class, Driver=cp210x, 12M
        |__ Port 4: Dev 12, If 1, Class=Human Interface Device, Driver=usbhid, 1.5M
        |__ Port 4: Dev 12, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
        |__ Port 5: Dev 4, If 0, Class=Human Interface Device, Driver=usbhid, 12M
        |__ Port 5: Dev 4, If 1, Class=Human Interface Device, Driver=usbhid, 12M
        |__ Port 5: Dev 4, If 2, Class=Human Interface Device, Driver=, 12M
GIMX adapter detected, controller type is: XOnePad.
Reset sent to the GIMX adapter.
found pass-through device 0x045e:0x02d1
registered joystick 0 with name "Microsoft X-Box One pad"
using default refresh period: 4.00ms
mouse 0 has name 'Corsair Corsair Gaming HARPOON RGB Mouse' and virtual id 0
mouse 1 has name 'Corsair Corsair Gaming HARPOON RGB Mouse' and virtual id 1
mouse 2 has name 'dakai PS/2+USB Keyboard' and virtual id 0
keyboard 0 has name 'Corsair Corsair Gaming HARPOON RGB Mouse' and virtual id 0
keyboard 1 has name 'dakai PS/2+USB Keyboard' and virtual id 0
keyboard 2 has name 'dakai PS/2+USB Keyboard' and virtual id 1
joystick 0 has name 'Microsoft X-Box One pad' and virtual id 0
joystick 1 has name 'Corsair Corsair Gaming HARPOON RGB Mouse' and virtual id 0
Dump of /home/pi/.gimx/config/XOnePadUsb.xml:
<?xml version="1.0" encoding="UTF-8"?>
<root>
  <controller id="1" dpi="0" type="XOnePad">
    <configuration id="1">
      <trigger type="" id="" name="" button_id="" switch_back="no" delay="0"/>
      <mouse_options_list/>
      <intensity_list/>
      <button_map>
        <button id="abs_axis_9" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="button" id="0"/>
        </button>
        <button id="abs_axis_8" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="button" id="1"/>
        </button>
        <button id="abs_axis_10" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="button" id="2"/>
        </button>
        <button id="abs_axis_7" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="button" id="3"/>
        </button>
        <button id="abs_axis_11" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="button" id="4"/>
        </button>
        <button id="abs_axis_12" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="button" id="5"/>
        </button>
        <button id="abs_axis_0" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="button" id="6"/>
        </button>
        <button id="abs_axis_1" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="button" id="7"/>
        </button>
        <button id="abs_axis_2" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="button" id="8"/>
        </button>
        <button id="abs_axis_15" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="button" id="9"/>
        </button>
        <button id="abs_axis_16" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="button" id="10"/>
        </button>
        <button id="abs_axis_3" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="button" id="11"/>
        </button>
        <button id="abs_axis_5" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="button" id="13"/>
        </button>
        <button id="abs_axis_6" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="button" id="14"/>
        </button>
        <button id="abs_axis_4" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="button" id="12"/>
        </button>
      </button_map>
      <axis_map>
        <axis id="rel_axis_0" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="axis" id="0" dead_zone="0" multiplier="0.004" exponent="1" shape="Circle"/>
        </axis>
        <axis id="rel_axis_1" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="axis" id="1" dead_zone="0" multiplier="0.004" exponent="1" shape="Circle"/>
        </axis>
        <axis id="rel_axis_2" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="axis" id="3" dead_zone="0" multiplier="0.004" exponent="1" shape="Circle"/>
        </axis>
        <axis id="rel_axis_3" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="axis" id="4" dead_zone="0" multiplier="0.004" exponent="1" shape="Circle"/>
        </axis>
        <axis id="abs_axis_13" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="axis" id="2" dead_zone="0" multiplier="0.008" exponent="1" shape=""/>
        </axis>
        <axis id="abs_axis_14" label="">
          <device type="joystick" id="0" name="Microsoft X-Box One pad"/>
          <event type="axis" id="5" dead_zone="0" multiplier="0.008" exponent="1" shape=""/>
        </axis>
      </axis_map>
      <joystick_corrections_list/>
    </configuration>
  </controller>
</root>
Haptic core has source haptic_source_rumble for device 045e:02d1
No haptic sink found for joystick 0 (Microsoft X-Box One pad)
Press the guide button to activate the controller.
Exiting

kamperkilla87
Posts: 90
Joined: Tue Mar 13, 2018 7:10 am

Re: Gimx adapter & Rpi3 model B

Post by kamperkilla87 » Sun Mar 25, 2018 4:24 am

I spent a good bit of Friday, an all of Saturday trying to get this working. It's now Sunday an idk what else to do. Matlo I used the curses option an all buttons seem to be registering, including the guide button. Idk if it's the configs themselves or what. Another question. The controller I have connected to the Pi. Should batteries be in it? And should I power it on or what? Note I've tried it on two different Pi's. Both Pi 3 model b. Also I get a message in gimx config stating profile 1 an 2 bindings do not match.

User avatar
Matlo
Posts: 5015
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: Gimx adapter & Rpi3 model B

Post by Matlo » Sun Mar 25, 2018 8:01 am

kamperkilla87 wrote:
Sat Mar 24, 2018 11:07 pm
guide button is mapped to thew number 8
I'm not seeing this mapping in the log you provided. Maybe you did not select the right configuration?
GIMX creator Donate Shop

kamperkilla87
Posts: 90
Joined: Tue Mar 13, 2018 7:10 am

Re: Gimx adapter & Rpi3 model B

Post by kamperkilla87 » Sun Mar 25, 2018 4:38 pm

I managed to actually talk to my Xbox with keyboard an mouse using a battlefield 1 config. I believe made by Godlike. I try editing the config an it no longer works. I have got it working with the original battlefield 1 config, but not with a edited version. As soon as I hit start in the gimx launcher the Xbox controller plugged into the Pi shuts off. With no communicate between the keyboard an mouse to Xbox.

User avatar
GoDlike
Posts: 496
Joined: Thu Apr 28, 2016 12:47 pm
Location: Poland

Re: Gimx adapter & Rpi3 model B

Post by GoDlike » Sun Mar 25, 2018 5:19 pm

That's configuration made for PlayStation 4. It will not work correctly. You should make your own config instead.
My hardware: Xbox 360 S "Trinity" RGH | PS3 Slim CFW 4.80 | PS4 6.00 | Mouse: 8 years old Gigabyte M8000x :mrgreen:
My Steam: http://steamcommunity.com/id/Godlike_RU/ | PSN: GoDlike_RU

Post Reply