XB1 sees gimx controller only if I disconnect/reconnect real xb1 controller

Need help? Ask here and someone will help
Post Reply
dapharsyde
Posts: 9
Joined: Sat Dec 06, 2014 10:14 pm

XB1 sees gimx controller only if I disconnect/reconnect real xb1 controller

Post by dapharsyde » Sun Dec 31, 2017 1:56 am

I am having a strange issue with my XB1 detecting the gimx controller after I physically disconnect it from the XB1. After reattaching to the XB1, and I restart gimx, the output appears to be normal. gimx detects the DIY adapter and it detects the real XB1 controller attached to the PC. However, the XB1 does NOT detect the gimx controller as being attached, even after sending the "guide" command.

The workaround I found for this is very strange. While gimx is still running, I disconnect the XB1 controller from the PC, and (as expected) gimx throws LIBUSB errors, and I kill gimx. I then reconnect the XB1 controller to the PC, and restart gimx. Without sending a "guide" command, the XB1 detects the gimx controller, and the interface works as expected.

If gimx is not running when I disconnect the XB1 controller, reattaching it does not fix the issue. It seems that disconnecting the controller while gimx is running is a required part of this workaround.

I am experiencing this issue on a Windows 10 system. I have another system running Windows 7 that does not have this problem. I have tested on multiple XB1's, with multiple cables and DIY adapters and eliminated those as culprits. I primarily run gimx 4.2 (to maintain compatibility with some older software I have), but I have also reproduced the same issue in the latest gimx release 6.11

I appreciate any insight to why this is happening, and if there is a solution that does not require me to disconnect/reconnect the XB1 controller each time I start gimx. Thank you!

User avatar
GoDlike
Posts: 498
Joined: Thu Apr 28, 2016 12:47 pm
Location: Poland

Re: XB1 sees gimx controller only if I disconnect/reconnect real xb1 controller

Post by GoDlike » Sun Dec 31, 2017 10:51 am

Please provide a log file so we can check
My hardware: Xbox 360 S "Trinity" RGH | PS3 Slim CFW 4.80 | PS4 6.00 | Mouse: 8 years old Gigabyte M8000x :mrgreen:
My Steam: http://steamcommunity.com/id/Godlike_RU/ | PSN: GoDlike_RU

User avatar
Matlo
Posts: 5016
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: XB1 sees gimx controller only if I disconnect/reconnect real xb1 controller

Post by Matlo » Sun Dec 31, 2017 10:58 am

This is a limitation due to the authentication.
GIMX creator Donate Shop

dapharsyde
Posts: 9
Joined: Sat Dec 06, 2014 10:14 pm

Re: XB1 sees gimx controller only if I disconnect/reconnect real xb1 controller

Post by dapharsyde » Sun Dec 31, 2017 11:26 pm

Matlo wrote:
Sun Dec 31, 2017 10:58 am
This is a limitation due to the authentication.
Hi Matlo -

Can you provide some clarification to this? I don't have this issue on my other system that runs Windows 7 - is this authentication issue specific to Windows 10?

Post Reply