Gran Turismo Sport Logitech G27 RPi not working

Need help? Ask here and someone will help
Post Reply
Duckferd
Posts: 1
Joined: Wed Oct 25, 2017 2:03 pm

Gran Turismo Sport Logitech G27 RPi not working

Post by Duckferd » Wed Oct 25, 2017 2:12 pm

Hi all,

I've been able to use GimX running on PC with a homebuilt adapter to play Gran Turismo Sport with a Logitech G27, thanks to the community here. It's annoying that Sony/Logitech can't implement native G27 support on PS4 considering it's a expensive peripheral, so GimX is a real life saver.

Recently, I've been trying to run GimX via a 'plug and play' dietpi version, as found on Steve Marton's website (http://www.steve-marton.com/gimx/?p=180). I am using a Raspberry Pi Zero W with a 4-port USB hat and 2A adapter, and same homebuilt USB-UART. What I found was that while I can boot into Gran Turismo Sport and use all the buttons and such; as soon as I load into a race, my G27 disconnects (the green LED on my shifter control pad dies).

Any ideas? Since I'm a complete RPi noob, can anyone point out how I can extract a log to understand what's happening? I'm also going to be purchasing a RPi 3 (with built-in USB ports) to try out but I'm not sure if I'll run into the same problems.

ricky
Posts: 5
Joined: Thu Jan 14, 2016 2:36 am

Re: Gran Turismo Sport Logitech G27 RPi not working

Post by ricky » Thu Oct 26, 2017 2:23 am

Grand turismo sport
Dont know with rpi w zero... (dont have to try)
Rpi 3 +usb adapter g27 running dietpi (not updated) work great
Rpi 3 +usb adapter g25 running dietpi (not updated) work great
Using default image work great
Tryed update dietpi and gimx and stop working...
(Need more time to try again)

Post Reply