DFGT pedals not config correctly :( Need help please

Need help? Ask here and someone will help
sanchez69er
Posts: 6
Joined: Sun Apr 24, 2016 6:40 pm

DFGT pedals not config correctly :( Need help please

Post by sanchez69er » Sun Apr 24, 2016 6:51 pm

Hi,

I am all set up on a pc with the diy usb board running on a pS4 playing drive club, the steering is fine and works perfectly but the pedals are not quite right. The issue is when I press my gas pedal it has 100% acceleration and same with my brake pedal just touch it slightly and its 100% brakes. How do i set it up for progressive acceleration and braking? I have tried all sorts of setting with no luck. Please help somebody, Thanks Karl

sanchez69er
Posts: 6
Joined: Sun Apr 24, 2016 6:40 pm

Re: DFGT pedals not config correctly :( Need help please

Post by sanchez69er » Sun Apr 24, 2016 7:00 pm

Code: Select all

option -l with value `log.txt'
option -c with value `logitech2.xml'
option -p with value `COM5'
status flag is set
subpos flag is set
force_updates flag is set
GIMX 5.7 x86_64
Windows 10 (or later) x64
Kernel version: 10.0 (10586)
native mode is already enabled for HID device \\?\hid#vid_046d&pid_c29a#7&13f2278e&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030} (PID=c29a)
Detected USB adapter: G29 PS4.
using default refresh period: 5.00ms
Warning: can't open macro directory C:\Users\Karlos\AppData\Roaming//gimx//macros/
0 1461524334.112603, wheel (-41)
0 1461524334.708092, wheel (-20)
0 1461524334.722806, wheel (-2)
0 1461524334.732783, wheel (16)
0 1461524334.737784, wheel (35)
0 1461524334.747793, wheel (56)
0 1461524335.092943, wheel (74)
0 1461524335.137994, wheel (95)
0 1461524335.173026, wheel (113)
0 1461524335.263051, wheel (134)
0 1461524335.318155, wheel (134), PS (255)
0 1461524335.418233, wheel (27), PS (255)
0 1461524335.438264, wheel (35), PS (255)
0 1461524335.443269, wheel (41), PS (255)
0 1461524335.468291, wheel (41)
0 1461524335.848580, wheel (35)
controller 0 configuration 0 axis gas intensity: 27328
0 1461524336.207957, wheel (35), cross (255)
0 1461524336.212950, wheel (41), cross (255)
0 1461524336.232966, wheel (45), cross (255)
0 1461524336.273016, wheel (51), cross (255)
0 1461524336.298038, wheel (56), cross (255)
0 1461524336.313052, wheel (62), cross (255)
0 1461524336.323062, wheel (68), cross (255)
Last edited by sanchez69er on Sun Apr 24, 2016 7:41 pm, edited 1 time in total.

User avatar
Matlo
Posts: 4250
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: DFGT pedals not config correctly :( Need help please

Post by Matlo » Sun Apr 24, 2016 7:02 pm

Hi,
Did you try the LogitechDrivingForceGT_G29.xml config that can be downloaded using the Help>Get configs menu in gimx-launcher?
Donate Shop

sanchez69er
Posts: 6
Joined: Sun Apr 24, 2016 6:40 pm

Re: DFGT pedals not config correctly :( Need help please

Post by sanchez69er » Sun Apr 24, 2016 7:05 pm

Yes i tried that but it would not reckonise the steering wheels saying joystick not found, so I had to configure every button and I got it working except the pedal issue.

User avatar
Matlo
Posts: 4250
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: DFGT pedals not config correctly :( Need help please

Post by Matlo » Sun Apr 24, 2016 11:01 pm

Please open your config file with a text editor, and post its contents.
Donate Shop

sanchez69er
Posts: 6
Joined: Sun Apr 24, 2016 6:40 pm

Re: DFGT pedals not config correctly :( Need help please

Post by sanchez69er » Mon Apr 25, 2016 3:21 pm

Here's the config

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<root>
  <controller id="1" dpi="0" type="G27 PS3">
    <configuration id="1">
      <trigger type="joystick" id="0" name="Driving Force GT" button_id="23" switch_back="no" delay="0"/>
      <mouse_options_list/>
      <intensity_list>
        <intensity control="abs_axis_17" dead_zone="32" shape="" steps="3">
          <up type="joystick" name="Driving Force GT" id="0" button_id="0"/>
        </intensity>
      </intensity_list>
      <button_map>
        <button id="abs_axis_2" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="button" id="20"/>
        </button>
        <button id="abs_axis_0" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="button" id="15"/>
        </button>
        <button id="abs_axis_1" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="button" id="9"/>
        </button>
        <button id="abs_axis_3" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="button" id="21"/>
        </button>
        <button id="abs_axis_4" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="button" id="22"/>
        </button>
        <button id="abs_axis_5" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="button" id="23"/>
        </button>
        <button id="abs_axis_6" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="button" id="24"/>
        </button>
        <button id="abs_axis_7" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="button" id="3"/>
        </button>
        <button id="abs_axis_8" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="button" id="2"/>
        </button>
        <button id="abs_axis_10" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="button" id="1"/>
        </button>
        <button id="abs_axis_9" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="button" id="0"/>
        </button>
        <button id="abs_axis_11" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="button" id="5"/>
        </button>
        <button id="abs_axis_12" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="button" id="4"/>
        </button>
        <button id="abs_axis_13" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="button" id="7"/>
        </button>
        <button id="abs_axis_14" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="button" id="6"/>
        </button>
        <button id="abs_axis_15" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="button" id="11"/>
        </button>
        <button id="abs_axis_16" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="button" id="10"/>
        </button>
        <button id="abs_axis_18" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="axis down" id="2" threshold="-10"/>
        </button>
        <button id="abs_axis_17" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="axis down" id="1" threshold="-10"/>
        </button>
      </button_map>
      <axis_map>
        <axis id="rel_axis_0" label="">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="axis" id="0" dead_zone="0" multiplier="0.002" exponent="1.00" shape=""/>
        </axis>
        <axis id="abs_axis_18" label="brake">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="axis" id="3" dead_zone="50" multiplier="0.008" exponent="0.00" shape=""/>
        </axis>
      </axis_map>
      <joystick_corrections_list>
        <correction low_value="32767" low_coef="8192" high_value="0" high_coef="1">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="axis" id="1"/>
        </correction>
        <correction low_value="32767" low_coef="8192" high_value="0" high_coef="1">
          <device type="joystick" id="0" name="Driving Force GT"/>
          <event type="axis" id="2"/>
        </correction>
      </joystick_corrections_list>
    </configuration>
  </controller>
</root>

sanchez69er
Posts: 6
Joined: Sun Apr 24, 2016 6:40 pm

Re: DFGT pedals not config correctly :( Need help please

Post by sanchez69er » Tue Apr 26, 2016 6:36 pm

So I changed the low coef to minus 8192 and that seemed to sort the acceleration out but I still have the issue with the brake, there is no progression,if you press the pedal a little bit full brakes are applied. Any help please ?

User avatar
Matlo
Posts: 4250
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: DFGT pedals not config correctly :( Need help please

Post by Matlo » Tue Apr 26, 2016 6:47 pm

Donate Shop

sanchez69er
Posts: 6
Joined: Sun Apr 24, 2016 6:40 pm

Re: DFGT pedals not config correctly :( Need help please

Post by sanchez69er » Thu May 12, 2016 6:32 am

Thank you, this works well :)

karrott
Posts: 1
Joined: Wed Jul 05, 2017 11:13 pm

Re: DFGT pedals not config correctly :( Need help please

Post by karrott » Wed Jul 05, 2017 11:16 pm

Matlo wrote:
Tue Apr 26, 2016 6:47 pm
Try this config:
http://pastebin.com/MD60MNzw
Hello,

How do I use this config? I clicked the link and then downloaded the text file. But what do I do from there? What is the step by step process for using this config file?

My issue is that my gas pedal is my brake and the brake pedal does not work at all.

Post Reply